Basic EIGRP Configuration | Cisco Router

Enhanced Interior Gateway Routing Protocol (EIGRP) is an open-standard distance vector protocol developed by Cisco.  Routers running EIGRP must form neighbors before they can begin to exchange routes.  The multicast address for EIGRP communication is over 224.0.0.10.

In this lab we will configure four routers running EIGRP Autonomous System 10.  Only routers with the same AS can communicate together.

Configuration
GigabitEthernet0/0 are 24bit CIDR (255.255.255.0)
Loopback0 are 32bit CIDR (255.255.255.255)

R1#show ip int brief 
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.1     YES manual up                    up       
Loopback0                  1.1.1.1         YES manual up                    up      
!
R2#show ip int brief 
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.2     YES manual up                    up        
Loopback0                  2.2.2.2         YES manual up                    up      
!
R3#show ip int brief 
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.3     YES manual up                    up       
Loopback0                  3.3.3.3         YES manual up                    up      
!
R4#show ip int brief 
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.4     YES manual up                    up       
Loopback0                  4.4.4.4         YES manual up                    up 
R1(config)#router ?
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
!
R1(config)#router eigrp ?
  <1-65535>  Autonomous System
  WORD       EIGRP Virtual-Instance Name
!
R1(config)#router eigrp 10
R1(config-router)#?
  network              Enable routing on an IP network
R1(config-router)#network 192.168.1.0
R1(config-router)#network 1.1.1.1 0.0.0.0
!
R2(config)#router eigrp 10
R2(config-router)#network 192.168.1.0
R2(config-router)#network 2.2.2.2 0.0.0.0
!
R3(config)#router eigrp 10
R3(config-router)#network 192.168.1.0
R3(config-router)#network 3.3.3.3 0.0.0.0
!
R4(config)#router eigrp 10
R4(config-router)#network 192.168.1.0
R4(config-router)#network 4.4.4.4 0.0.0

Verification

R4#
*Nov  4 03:55:30.551: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 192.168.1.1 (GigabitEthernet0/0) is up: new adjacency
*Nov  4 03:55:30.561: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 192.168.1.2 (GigabitEthernet0/0) is up: new adjacency
*Nov  4 03:55:30.562: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 192.168.1.3 (GigabitEthernet0/0) is up: new adjacency
!
R1#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
2   192.168.1.4             Gi0/0                    13 00:05:58   18   108  0  11
1   192.168.1.3             Gi0/0                    11 00:06:20   14   100  0  11
0   192.168.1.2             Gi0/0                    14 00:07:56   10   100  0  10
!
R1#show ip eigrp interfaces 
EIGRP-IPv4 Interfaces for AS(10)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Gi0/0                    3        0/0       0/0          14       0/0           56           0
Lo0                      0        0/0       0/0           0       0/0            0           0
!
R1#show ip eigrp topology 
EIGRP-IPv4 Topology Table for AS(10)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 4.4.4.4/32, 1 successors, FD is 130816
        via 192.168.1.4 (130816/128256), GigabitEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/0
P 2.2.2.2/32, 1 successors, FD is 130816
        via 192.168.1.2 (130816/128256), GigabitEthernet0/0
P 3.3.3.3/32, 1 successors, FD is 130816
        via 192.168.1.3 (130816/128256), GigabitEthernet0/0
P 1.1.1.1/32, 1 successors, FD is 128256
        via Connected, Loopback0
!
R1#show ip route eigrp 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/130816] via 192.168.1.2, 00:08:47, GigabitEthernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/130816] via 192.168.1.3, 00:07:14, GigabitEthernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/130816] via 192.168.1.4, 00:06:52, GigabitEthernet0/0
!
R1#ping 2.2.2.2 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
R1#ping 3.3.3.3 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/6 ms
R1#ping 4.4.4.4 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/7 ms

EIGRP Wireshark capture from R1

Topic discussion at CLI Warriors - Forum